stryhのノート ~stryh/changelog

その2

「スクリプトがDBアクセスできるなんて」と思っていましたが出来るんですね。

スゲー!

  • OS-Windows XP Service Pack2
  • Ruby-1.8.6
  • RDBMS-PostgreSQL 8.3.0

DBIを使用してDB接続をしRDBMS(ここではポスグレ)のヴァージョンを取得する単純なプログラム。

DBIを現時点で最新の「0.2.0」を使用すると

`load_driver’: Could not load driver (no such file to load — Pg) (DBI::InterfaceError)

というエラーがでるんですよ~。

しかし、DBIの「0.1.1」にヴァージョンダウンし上記のプログラムを実行するとDB接続に成功するんですよ。

DBIのライブラリーに原因なのか、それとも他に原因があるのかは今のところは不明。

誰か分かる方がいれば教えていただきたい!ぐらいです。

UNIXでも同様のエラーは出ます。

URL :
TRACKBACK URL :

Leave a reply

*
*
* (公開されません)

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

Return Top